Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:

THEMA:

HoTT Telmetriesensor auf Jeti 03 Mär 2017 19:23 #7

  • rchajue
  • rchajues Avatar
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Beiträge: 31
  • Dank erhalten: 5
Hallo zusammen,

ich habe den Konverter auch nachgebaut. Das Flashen hat gut geklappt.
Mit dem Hott Vario habe ich bisher die besten Ergebnisse. Das Erkennen dauert immer etwas, aber dann wird es im Sensoren Menü mit den beiden möglichen Messungen Höhe und Vario angezeigt. Diese Werte lassen sich auch anzeigen. Allerdings erscheint mir der Wert für Höhe um den Faktor 10 zu gering. Vom Boden bis zur Decke variiert der Wert zwischen 0,1 und 0,2 Meter. Bei dem Höhenmesser von Tero habe ich eine Spanne von 0 bis 2 Meter, was ungefähr der Realität entspricht.
Das Vario zeigt auch Stiegen/Sinken an, aber da kann ich die Korrektheit der Werte nicht abschätzen.
Als weitere Sensoren habe ich noch ein GPS 33600, ein General Engine Modul 33610 und ein Voltage Modul 33631 getestet.
Das GPS wird als Hott GPS um Sensormenü angezeigt, die beiden anderen Sensoren jeweils als Hott GAM. In keinem Fall werden aber die möglichen Messungen (Höhe, Position Spannung, Strom usw.) angezeigt. So kann man sich keinerlei Werte anzeigen lassen.
Zum Test habe ich einen non EX und einen EX Empfänger verwendet.
Sender DC16 4.22, RX R8 alt und REX6 1.01.

Gruß
HaJue

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

HoTT Telmetriesensor auf Jeti 04 Mär 2017 18:47 #8

  • rchajue
  • rchajues Avatar
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Beiträge: 31
  • Dank erhalten: 5
Bin etwas weiter. Habe eigentlich keine Ahnung vom Programmieren, aber mir ist aufgefallen, dass die nicht getesteten Sensoren im Code quasi ausgeklammert waren (/* */). Diese Zeichen kamen mir von SQL her bekannt vor. Das GAM habe ich jetzt mal 'aktiviert' und siehe da: Die Akkuspannung wird korrekt angezeigt. Zu weiteren Tests habe ich jetzt keine Zeit. Vielleicht morgen. Einziges Phänomen: Beim Vario wird der Name nicht mehr auf der DC16 im Menü angezeigt. Die Messwerte auswählen kann man aber schon?!

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

HoTT Telmetriesensor auf Jeti 05 Mär 2017 09:15 #9

  • enKo
  • enKos Avatar Autor
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Beiträge: 67
  • Dank erhalten: 12
Hallo zusammen,

zunächst bitte ich um Entschuldigung, dass ich erst einen Post ins Forum setze und dann nicht weiter darauf antworte.
Ich hatte mich hier auf die Email-Benachrichtigung verlassen. Diese hat mich nur bei der ersten Antwort informiert, dann nicht weiter.
Hatte daher angenommen, dass hier im Moment kein großes Interesse besteht und auch nicht selbst nachgeschaut.
Kann ich das irgendwie einstellen, dass ich bei einem neuen Post zu einem Thema immer informiert werde?

Umso mehr freut es mich sehr, dass es erste Nachbauten gibt, uns diese auf (weitestgehend ;) ) funktionieren.

Zu den einzelnen Fragen:
@Klippeneck/@onki: das erstmalige Erkennen der Sensorwerte dauert tatsächlich etwas. Das liegt, soweit ich das verstanden habe, an der Bibliothek von Bernd, die ich für die Kommunikation verwende. Diese sendet die Info's, welche Sensorwerte es gibt, relativ selten.
Beim erneuten einschalten ist es so, dass das Erkennungsmodul zunächst 3s nichts macht und wartet, bis die HoTT-Geräte gestartet sind. Dann versucht es in einer Endlosschleife, das angeschlossene Gerät zu erkennen. (=lange Blicksignale) Sobald eines gefunden wurde, werden die Daten ausgelesen und an den Jeti-Empfänger geschickt. (=kurze Blinksignale) Beginnt man zu früh mit der Suche, meldet sich z.B. ein ESC als GAM. Diese Erkenntnis hat mich 2 Wochen Suche gekostet.

@Klippeneck/@rchajue: an Ergebnissen mit Versuchen mit anderen HoTT-Geräten hätte ich großes Interesse. Derzeit ist das Protokoll für alle HoTT-Sensoren programmiert, aber alle bis auf Vario und ESC auskommentiert. Ich wollte nicht ungeprüften Quellcode in die Flieger packen, auch wenns "nur" Telemetrie-Info's sind. Sobald die Daten aber geprüft und bestätigt oder ggf. korrigiert sind, ändere ich das.

@rchajue: dem mit dem Faktor 10 bei der Vario Höhe gehe ich nach. Ich melde mich.

Wenn es weitere Fehler (oder auch nur Verdachtsfälle) oder Ideen gibt werde ich die Software gerne optimieren.

VG,
Norbert
Folgende Benutzer bedankten sich: rchajue

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

HoTT Telmetriesensor auf Jeti 05 Mär 2017 17:55 #10

  • rchajue
  • rchajues Avatar
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Beiträge: 31
  • Dank erhalten: 5
Heute konnte ich ein wenig testen. Dabei kam folgendes heraus:

- Vario, GAM und Voltage-Module sind nutzbar
- zu den Werten vom Vario siehe mein vorheriges Posting



- beim GAM funktionieren Main Voltage, Capacity und Current
- Spannung und Strom habe ich mit einem Multimeter überprüft
- die Kapazitätsanzeige erschien überschlägig gerechnet plausibel



- die Anzeige der Einzelzellenspannung funktioniert beim GAM nicht
- die ersten drei Zellen wurden mit 0,2V, die vierte Zelle mit 0,0V angezeigt - real waren es etwa 3,8V

- sobald ich im Code das GPS 'freischalte', funktioniert nichts mehr
- es sieht so aus, als ob die Sensoren nicht mehr erkannt werden - die LED in der Nähe von Pin 10 und 11 leuchtet dauerhaft
- ohne das GPS dauert die Sensorerkennung um 5 Sekunden - Sensor anstecken - LED geht kurz aus - Dauerleuchten - Sensor erkannt - LED blinkt (entsprechend Datenübertragung zwischen Sensor und Arduino?)
- ich habe dann mal testweise den ESC rausgenommen - ändert nix
- GPS wieder raus und alles ist gut

vorläufiges Fazit: Der Konverter funktioniert schon recht gut. Das GAM ist so für mich absolut brauchbar. Die Einzelzellenspannungen brauche ich persönlich nicht. Wenn das Vario jetzt noch sauber konvertiert würde, wäre das schon sehr gut! GPS nutzen wäre dann das Sahnehäubchen. Vor allem deshalb, weil die Dinger nicht so ganz billig sind.
Folgende Benutzer bedankten sich: enKo

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

HoTT Telmetriesensor auf Jeti 05 Mär 2017 19:33 #11

  • enKo
  • enKos Avatar Autor
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Beiträge: 67
  • Dank erhalten: 12
Hallo rchajue,

danke für deine Tests.

Der Reihe nach:
  • Den Fehler mit der falschen Höhe kann ich bestätigen.
    Ist korrigiert. Die aktuelle Version wieder ist hier verfügbar.
  • Die Einzelzellenauswertung würde ich gerne näher untersuchen. Hier bräuchte ich aber einen Datensatz aus einem GAM. Ich würde dir die Tage eine PM schicken mit einer Anleitung, wie du den bekommt. Wär' das ok?
  • Das mit dem aktivierten GPS nichts mehr geht ist ein Speicherproblem. Bernd (Sepp62) ist das Problem bekannt. Evtl. gibts dafür eine Lösung.
    Vorerst müsste es funktioniere, alles ausser GPS zu deaktivieren.
  • Auf die Messung selbst hat der Konverter keinen Einfluss. Wenn z.B. das GAM die Kapazität falsch berechnet und damit einen falschen Wert Richtung HoTT-Empfänger schickt, wird der Konverter dies weder erkennen noch berichtigen, sondern diesen falschen Wert in die Jett-Sprache übersetzten und weiter geben.

VG,
Norbert

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

HoTT Telmetriesensor auf Jeti 05 Mär 2017 20:19 #12

  • rchajue
  • rchajues Avatar
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Beiträge: 31
  • Dank erhalten: 5
Den Datensatz aus dem GAM schicke ich dir gerne.
Inzwischen habe ich die Einzelzellenspannungen zur Sicherheit mal unter Hott überprüft. Mit einem GR16 und meiner MX20 werden sie korrekt angezeigt.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Ladezeit der Seite: 0.199 Sekunden
Powered by Kunena Forum