Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:
  • Seite:
  • 1
  • 2

THEMA: Servomonitor und PWM

Servomonitor und PWM 09 Jun 2018 18:28 #1

  • heliuwe
  • heliuwes Avatar Autor
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Beiträge: 41
  • Dank erhalten: 0
Hallo, ich stehe gerade auf dem Schlauch.....

Wie schon aus dem Thema herauszulesen ist, möchte ich gerne wissen, warum die PWM meines Reglers mit dem Servomonitor nicht übereinstimmt.

Es handelt sich um einen Mezon-Regler 90 RPM. Der Regler wurde bis vor kurzem in Verbindung mit einem V-Stabi mit Drehzahlregelung in einem Scaleheli verwendet.
Nun möchte ich den Regler nicht mehr über das V-Stabi ansteuern, sondern direkt über den Drosselkanal am Empfänger. Dazu habe ich auch den InitPoint auf Auto eingestellt. In Verbindung mit der V-Stabi-Regelung waren der Anfangs und der Endpoint gefixed.
Der Drosselkanal geht nun von Motor aus (-100%) bis zu meinen geforderten Drehzahlen, +73%. Das Signal aus dem Empfänger funktioniert, habe ich über ein Servo kontrolliert.

Nun läuft der Motor zwar, aber auf volle Leistung.
Ich erreiche nur eine Drehzahlminderung, wenn ich zwischen -100% und 0% bin, dann regelt der Mezon runter. Bei -35% habe ich meine geforderte Drehzahl im System, die PWM in der Telemetrie zeigt mir aber nur 25%.

Was mache ich falsch? Warum hat das vorher funktioniert? Ist Motor "aus" beim Mezon etwa 0%?

Ich steuere die Drehzahlregelung nicht mehr über das FBL, weil es mir schon zweimal den Motor ausgeschaltet hat, ich wollte wieder Vertrauen in die Technik aufbauen.

Ich komme nicht weiter......

Grüße, Uwe.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Servomonitor und PWM 09 Jun 2018 22:01 #2

  • HNAGL
  • HNAGLs Avatar
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Beiträge: 4597
  • Karma: 20
  • Dank erhalten: 2167
Hallo Uwe,
Wenn man den Initpoint auf Auto stellt, wird die minimale und maximale Pwnstellung vom Regler erkannt und als Min bzw.
Maxstellung übernommen. Stelle ihn auf fixe 1.000ms und 2.000ms und du hast die gewünschte 3/4 Gasstellung bei +73%.
Mfg Harald

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Servomonitor und PWM 10 Jun 2018 15:22 #3

  • heliuwe
  • heliuwes Avatar Autor
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Beiträge: 41
  • Dank erhalten: 0
Hallo Harald,
danke für den Tip, werde es ausprobieren und gebe dann ein Feedback.
Grüße, Uwe.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Servomonitor und PWM 12 Jun 2018 18:56 #4

  • heliuwe
  • heliuwes Avatar Autor
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Beiträge: 41
  • Dank erhalten: 0
Hallo,
leider keine Verbesserung, der Regler reagiert nur auf den "Servoweg" laut Servomonitor von -100bis 0%. Da lässt sich die Drehzahl regulieren. Über 0% "Servoweg" im Servomonitor des Senders ist er auf max. Leistung und keine Regelung. Bei -42% im Servomonitor des Senders habe ich meine gewünschte Systemdrehzahl von 1251 U/min, PWM laut LOG 29%, HÄÄÄ???
Irgendwie verkehrte Welt.
Hilfe, oder kann ich so fliegen?
Grüße, Uwe.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Servomonitor und PWM 13 Jun 2018 18:27 #5

  • MichaFranz
  • MichaFranzs Avatar
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Beiträge: 1344
  • Karma: 7
  • Dank erhalten: 409
Hallo Uwe,

"Hilfe, oder kann ich so fliegen?" ....Sicher nicht.

Für mich hört sich das so an das Du ungewollt den Regler neu/falsch angelernt hast.

Ich würde nun den Regler resetten und an einen anderen Empfänger und jungfräulichen Modellspeicher anschließen und dort die Gas Endpunkte neu anlernen.

Danach klappt er sicher auch wieder im eigentlichen Modell/Speicher.

Viel Erfolg,

Micha

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Servomonitor und PWM 13 Jun 2018 18:54 #6

  • HNAGL
  • HNAGLs Avatar
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Beiträge: 4597
  • Karma: 20
  • Dank erhalten: 2167
Man muss sich halt auch selbst mit der Materie beschäftigen. Es steht doch schon genau in meinem Post!









PWN Stellung des Mezons zur Kontrolle:



Das hast du so laut meinem Post eingestellt?
Wenn du das gemacht hast dann geht es auch!!!

MFG Harald

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Seite:
  • 1
  • 2
Ladezeit der Seite: 0.391 Sekunden
Powered by Kunena Forum