Programmierlösung für Bugservo

25 Jun 2015 21:47 #1 von Lattinger
Hallo,

Ich habe ein Problem mit meiner Fahrwerkselektronik.
Normalerweise wird das Servo zur Bugradsteuerung bei einziehen des Fahrwerks abgeschaltet,
Außerdem kann man eine Mittelstellung unabhängig von der Servotrimmung für das Servo programmieren damit der Ruderhebel
beim ausfahren des Fahrwerks sauber ein rastet. Erst dann wird die Freigabe für Steuereingaben freigechaltet und die eingestellte Trimmung übernommen. Leider hat die Elektronik einen Macke und ein Steuern und auch die Trimmwerte werden nicht frei gegeben.

Jetzt wäre mein Frage, gibt es eine Möglichkeit diese Funktion über neuen DS16 zu realisieren.

LG
Michael

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

26 Jun 2015 11:41 - 26 Jun 2015 11:42 #2 von HNAGL
Hallo Michael,
Ja so etwas kann man programmieren.
Entweder trimmst du dein Lenkservo gemeinsam mit dem Seitenruder oder du machst dir eine separate Digitaltrimmung für das
Lenkservo.
Bei erster Variante nimmst du einem Mischer Seite auf Lenkung, stellst diesen auf separat und legst dir eine Flugphase Boden an.
In der normalen Flugphase hast du 0% Zumischung und die Option Trim deaktiviert. Am Boden dann halt z.B 50% und Trimmung aktiviert.

Mit einer separaten Digitaltrimmung kannst du diese nur in der Flugphase Boden aktivieren und in der normale Flugphase deaktivieren und über
die Funktionskurve konstant auf den benötigten Wert einstellen.

MFG Harald
Folgende Benutzer bedankten sich: Lattinger

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

26 Jun 2015 20:05 #3 von Lattinger
Hallo Harlad,

vielen Dank für deine Hilfe.
Ich denke ich werde mich für Variante 2 entscheiden.

LG
Michael

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

08 Jun 2016 15:26 - 08 Jun 2016 16:24 #4 von Wolf
Hallo
habe auch ein Problem mit der Programmierung vom Bugservo.

2 Wege Schalter schaltet BugFahrwerk eingezogen und Ausgezogen.Das ganze mit Dualrate 0 für FW Eingezogen.

Hab jetzt einen Gyro eingebaut.
Jetzt soll aber der Gyro für das Bugrad nur dann gehen wenn das Bugrad ausgefahren ist.
Da aber das Ausfahren ca.5 Sekunden dauert ,geht das Gyro aber schon sobalt der Befehl ausfahren kommt und verdreht das Rad beim ausziehen.Dadurch verklemmt es manchmal im Schacht.

Denke mal das das nur mit einer Zeitverzögerung für das Einschalten des Gyro geht .
evtl. mit einem Sequenzer ? oder was wäre da noch machbar ?

Gruß
Wolfgang

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

13 Jun 2016 15:39 #5 von Wolf
Hallo
Hab es jetzt geschaft ,mit einer Sequenz.
Fahrwerk lenkt nur wenn voll Ausgefahren und selbst wenn es verdreht ist stellt es auf mitte und zieht dann erst ein.
DC 16 ist einfach Spitze.

Gruß
Wolfgang

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Ladezeit der Seite: 0.109 Sekunden

Impressum